Chulalongkorn University Name

International School of Engineering Student ID
Department of Computer Engineering Station No.
2140105 Computer Programming Lab. Date

Lab 1 - An Introduction to Eclipse

Objectives:

e Learnto use Eclipse as Java integrated development environment.
e Practice basic java programming.

Background Knowledge

e Materials from 2140101 - Computer Programming for International Engineer.

Eclipse - an open development platform

Eclipse is an open source community, whose projects are focused on building an open
development platform comprised of extensible frameworks, tools and runtimes for building,
deploying and managing software across the lifecycle. A large and vibrant ecosystem of
major technology vendors, innovative start-ups, universities, research institutions and
individuals extend, complement and support the Eclipse platform

In this class, we will use Eclipse as a tool (IDE) for developing JAVA programs.

You will need a Java runtime environment (JRE) to use Eclipse. You may download the
Eclipse SDK at http.//www.eclipse.org/downloads/. You will get a Zip file, uncompress
(unzip) it in an empty folder. You are ready to run the Eclipse.

The Workbench

When the Workbench is launched the first thing you see is a dialog that allows you to select
where the workspace should be located as shown in Figure 1. The workspace is the directory
where your work will be stored.

¢ Your turn ©

Since this is the first time you use Eclipse, you need to create a workspace. Your
workspace will have the following name format, %desktop%\YourID, where
%desktop¥% is the location of your desktop and YourID is your student
identification. For example, if the desktop of your machine is “C:\Documents
and Settings\Chate\Desktop”, and your student ID is “5600 12343 21”,

your work space will be
“C:\Documents and Settings\Chate\Desktop\5001234321".

You should create a folder for your work and copy it. We will clean the hard
disk everyday. Do not expect your work will be in the computer next time you
work in the lab.

You will use the workspace you’ve just created for all labs in this course.
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After the workspace location is chosen, a single Workbench window is displayed as shown
in Figure 2. A Workbench window offers one or more perspectives. A perspective contains
editors and views, such as the Navigator. Multiple Workbench windows can be opened
simultaneously. Initially, in the first Workbench window that is opened, the Java
perspective is displayed, with only the Welcome view visible. Click the arrow labeled
Workbench in the Welcome view to cause the other views in the perspective to become
visible.

(You can get the Welcome view back at any time by selecting @ Help > Welcome.)

| Select a workspace

Eclipse SDK stores your projects in a folder called a workspace.
Choose & workspace folder to wse for this session,

werspoce %edlesKEon%\YourID. ) - [ Browse. |

Use this &5 the default and do not ask |g|in

g Captuss Pivvees |

Figure 2 - Eclipse Welcome page
Preparing Eclipse
In this section, you will verify that Eclipse is properly set up for Java development.

Verifying JRE installation and CLASSPATH variables

1. If you still see the Eclipse Welcome page, click the arrow icon to begin using Eclipse.
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2. Select the menu item #Window > Preferences... to open the workbench
preferences.

3. Select the #Java > Installed JREs preference page to display the installed Java
Runtime Environments as shown in Figure 3. Confirm that a JRE has been detected.
By default, the JRE used to run the workbench will be used to build and run Java
programs. It should appear with a checkmark in the list of installed JREs. We
recommend that you use a Java SDK instead of a JRE. An SDK is designed for
development and contains the source code for the Java library, easing debugging.
Additional SDKs can be added by searching the hard drive for installed SDKs. To do
so, simply click the Search... button and specify a root folder for the search. Select
the most recently version of the JRE.

Installed JREs e

add, remove or edit JRE definitions,
By default, the checked IRE is added ta the build path of newly created Java projects,

Installed JREs:

Mame Location Tvpe

w Standard Y

C:\Program Files\IBMY Javaldz
agrarm =3 dv3 Edit“.

Copy...

Search. ..

Figure 3 - Installed JREs preference page

4. Select the %=General > Workspace preference page as shown in Figure 4. Confirm
that the Build automatically option is checked.

Workspace Sl

See 'Startup and Shutdown' For workspace startup and shutdown preferences.

[/ ]
[ |Refresh autamatically

[ ]5ave automatically before build

Workspace save interval (in minutes): | S

Figure 4 - Workspace preference page

5. Select the FJava > Build Path preference page as shown in Figure 5. Confirm that
Source and output folder is set to Project.
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Build Path =T

Specify the build path entries used as defaulk by the Mew Java Project creation
wizard:

Source and oukput Falder
(%) Project
) Folders

Az JRE library use; | IRE conkainer "

Figure 5 - Java's Build Path preference page

6. Select the %5Java > Editor preference page as shown in Figure 6. Confirm that
option Report problems as you type is checked.

Editor =

Java editor preferences, Maote that some preferences may be set on the Text
Editors preference page,

amatt caret positioning at line skart and end
amart caret positioning in Java names (overrides platform behavior)
Report problems as wou bype

Also see the compiler warnings and spell checking preferences,

Figure 6 - Java's Editor preference page

7. Click on OK to save the preferences.

Creating your first Java project

0 Your turn ©®

Complete the following steps.

1. Creating a project.

Before we start working on a program, we must create a project for it. An Eclipse

project helps us organize our files, so that we do not mistakenly work on the wrong
program.

1.1. To create a project, go to File and choose new -> project as shown in Figure 7.

1.2. Since we are writing a Java program, choose Java Project.

1.3. Then type in your project names. Let's name it Lablvl. The name that we use is
case sensitive.
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1.4. At this point, we have two choices, next and finish. This is a simple project, so let's
choose finish. Our project will then be displayed on the left hand window. The
window is divided into 4 parts as shown in Figure 8. We can extend or move all
parts to anywhere we want.

Java - Eclipse Platform

Mave...

Rename...
Refresh

l—l i

Switch Workspace, .,

Alt+Shife+M

M| i Project...
B Package
1 (# Class
¥ Interface
&% Source Folder
% Folder
| | ¥ File

[E JUnit Test Case

Fz G visual Class
Fa
i Example...
“ Other..,

Cerl+m

Figure 7 - Create a new project
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Figure 8 - Eclipse IDE

Tip: Right clicking in the Eclipse Explorer window will also get you a pop-up menu for

creating your project.
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9. Creating your file.

9.1. Try creating you class (yes, it's your program) by choosing File-> New ->Class. You
can also do this by selecting from pop-up menu if you right click in the explorer
window.

9.2. A new Java class dialog will pop up, prompting you to fill in your class information as
shown in Figure 9.

9.3. Let's create a class called "Hello". Let this class have its main method. Do not select
Inherit abstract method. You can simply select the check boxes. Eclipse will
generate your main method structure for you, with lots of comments. You can
leave those comments in.

9.4. Let's write a program to print the word "Hello!" This is easy, but you've got to get
used to Eclipse, so do it now.

9.5. While you are writing your program, you may notice that your file name has a * in
it. This means your file has not been saved.

& Mew lava Class _-‘ & ¥ [ I ]
Java Class £ —Th
I, The use of the default package is discouraged. ku
Source folden: Labl/erc Browse...
Package: [def suit) Bromwse...
I Enclosing bype:
Mame G!"ﬂ )
Maodifiers: & publc default ad terted
abrstract fimal
Supercloss Jmalang Object | Browse..
Interfaces Al

Which method stubs would you like to create?
fic static void masn{String[] args)
Constructors from supereclass
ed abstract methods

Do you want to add comments as cnnrlgmﬂ in the properties of the cument project?

Generate comments

(¥ Finith _;'. Cancel

——

Figure 9 - New Java Class dialog

9.6. When you finish writing your program, try to run it without saving (select Run -> Run
As Java Application). Eclipse will prompt you to save your file at this point. What
you print will be shown in Eclipse's console window.

NOTE: Sometimes if your program won't run, try to save it manually first. This may
fix the problem.
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10. Importing file.

Sometimes you won't be writing your program from scratch. Importing is a way to copy
files into your project. You can do this by right click on your project name, and then
choose import. Eclipse will pop a form prompting you to choose what kind of
information will be imported as shown in Figure 10. We will mainly be using 2 import
sources:

e file system - normal copying of files into your project.
e archive file - import an unzip the .zip or .jar file (jar is Java's zip format) for you.

= Import

Select
h

Choose import source, E - 5

Select an impart source:

bype filker text

- Gl
[T, archive File
@cj Breakpaints
19 Existing Prajects into Warkspace
[, File System
EL Preferences

H-l=- CYS

#-[2 Plug-in Developrent

H-[2 Team

it 3 1l

Cancel

Figure 10 - Import dialog

10.1. Try importing the InsertionSort. jar file. (You may ask Lab. Instructor for a copy
of InsertionSort. jar)

10.2. Now, unzip the jar to any other folder, create a new project called Lab1v2 and try
to import the unzipped file.

11. Creating .jar file

Actually, jar (java archive) is zip, but we can also make .jar file executable. This will be

useful when you want to deploy your program in real use.

11.1. To create a jar file, right click on your project, and then select Export as shown
in Figure 11. Choose JAR file, name it (click Browse and change the folder to
Desktop, and type in yourname.jar), and select all options as shown in Figure 12
then click Next.

11.2. JAR Package option dialog is shown, click Next.

11.3. JAR Menifest Specification dialog is shown as in Figure 13. Click Browse.
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11.4.

11.5.
11.6.

Select main class window is shown. Select InsertionSort and then click OK as

shown in Figure 14.

Click Finish.

Go to Windows desktop and verify that your JAR file created in step 11.1 exists.
Double-click that file to run the executable jar file.

5 Expor!’

Select

Package resources into a JAR File on the local file system

=}
2]

Select an export destination:

& ant Buildfles

,@Archive file

@Deplnyahla features
%Deplnyable plug-ins and fragments
,EEcIipse product

1 IFile system

R
,@Javadoc
Erreferences

% Team Project Set

= Back I Mext = I Firiish

Cancel

Figure 11 - Export dialog

Deefine which resources should be experted into the JAR

Select the retoufces to export:

[ Labi | 9 [ classpath
[ test @ ¥ praject

4] generated class files and resources
. all patput folders for checked prajects
|7 Expost java source files and resources

L .Ewt:rlnﬂm‘hg&l’ur checked propects. Sefect iefactomnat.,

=
euugswnmmutwp\winmiunsu@n)

Options:

[ Compress the contents of the JAR fdle
[#] Add directory entries

[#] Ovenwrite existing files without warning

Figure 12 - Export JAR file
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JAR Manifest Specification
Customaze the manifiest file for the JAR file.

| Specify the manifest
@ Generate the manifest file
[ Sae the manifest in the workspace

i_- Eeuse and seve the manifest m the workspace

tetanedeat file: |

i Wse existing manifest from workspace

ttpnaest file: |

Seal contents:
) Seal the JAR
@ Seal sorme packages

Select the class of the application entry point:

Main class: | |

Figure 14 - Select main class window
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NOTE:

When you submit your homework, use .jar format, you must choose to export
generated class files and resources and export Java source files and resources.
Before sending your jar file to anywhere, try unzipping it to test if the jar creation

[ ]
[ ]
is correct.
Tips & Tricks

1. To let the editor show line numbers:
1.1. Go to menu Window, choose Preferences.
1.2. At General -> Editors -> Text Editors, check show line numbers as shown in Figure
15.

18 Preferences

type hiter text
l PPpearance
Capabilities
Compane/Patch
Content Types

e Aszociations

10 d Test Ec
Eey

Metwork Connections
I Pestpectives
Search
Startup and Shutdown
‘Web Browser
‘Welcome
Workipace
Ant
Connectrty
Ecore Diagram
Help
InstallUpdate
Intermet
s
IPA
Model Yahdation
Plug-in Development
Run/Debug
Senver

EFA Trmle

B

Text Editors
Undo hestory size: 200
Dusplayed tab wadthe 4

Inzert spaces for tabs

| Highlight current line
Show print margin

@ooe i)

/1 Shaw range indicator

| St wehitespace characters

| Enalble drag and drop of text

o« | 'Warn before editing a dermved file

] Smart caret positsoning a1 kine start and end

| Show affordance in hover on how to make it sticky

Appearance color options:

o
Current ling hlghllght e
Prnt margin

Find scope

Selection foreground color

Selection Iurl:grn-und codor

Backgraund caler

Foreground color

Hypeslnk

Meore colors can be configured on the Colors and Fonts prefi

| Restone Defaults | |

==

— D e —

Figure 15 - Text Editors preference page

2. If you want to find a bracket's corresponding pair, move the cursor behind the bracket.
Its pair will be shown.

w

Use Ctrl+Shift+F to layout your code beautifully.

4. If you are typing a long name, while typing, press Ctrl+Space. Eclipse will fill the rest of
the name for you or present choices for you to choose.
5. At Window menu, choose Show View. There are different views for looking at your
project. We will introduce 2 of them here:
5.1. package explorer - shows only parts related to writing programs.
5.2. navigator - shows everything in the project directory.
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6. If you want to change a variable name or file name, use Refactor. It is better than
search and replace because it updates all relationships with other project components
for you. To use refactor, select project name, class name, or anything that you want to
rename, and right-click then select Refactor -> Rename as shown in Figure 16.

|9 Java - InsertionSort. java - Eclipse SDK [:_]Lnﬂ@
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-5 4720084421 3 int index: @ insertionSort{int])
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B 4730253] Mave... Alt+Shift+y
(¥ 4 4730265¢ L1 Import... e —— :
12 4730285 .y Expart.. I Generc Type Arumets. .
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Figure 16 - Use Refactor to rename everything

7. When you are trying to run a program, make sure you are focusing on its file.

8. To run the program you run recently, click on Q-

9. When you are deleting a project, you can choose to delete content (delete all the files in
project folder). If you do not choose to delete content, Eclipse simply makes the project
invisible (the real files still exist).

Java review

Console Keyboard Input

import java.io.™;
public static void main(String[] args) throws I0Exception {
// define buffered for keyboard input
BufferedReader kbd = new BufferedReader(
new InputStreamReader(System.in));
// use readLine() to read a string from keyboard
System.out.print(“Enter your input: “);
String text = kbd.readLine();
// convert input string into an integer
int intlnput = Integer.parselnt(text);
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Keyboard Input Dialog
showInputDialog

public static String showInputDialog(Cbject message,
Object initialSelectionValue)

Shows a question-message dialog requesting input from the user, with the input
value initialized to initialSelectionvalue. The dialog uses the default frame, which usually
means it is centered on the screen.

Parameters:
message - the object to display
initialSelectionvalue - the value used to initialize the input field

import javax.swing.JOptionPane;
public static void main(String[] args) {
// use showlnputDialog to get input
String text = JOptionPane.showlnputDialog(“Enter your input: “);

b

Lab 1 Exercise

- Your turn

NOTE:
This is the first lab. Therefore it will be MUCH easier than future labs. Do not
take it for granted.
Prepare yourself by review material from previous semester.
Be on time.
You can help each other, but don't copy.
Do not hesitate to ask teacher and TA. (Try to solve the problem by yourself first.)
Use Java's help from java.sun.com or j2se6.chm.
When you finish each exercise, you will ask a lab's instructor to verify the results
and sign your lab. results' form. You should create a new project and new folder
for each exercise.

Write a Java program that prints to the screen all prime numbers from 2 to 1000,
ten numbers per line.

Write a Java program that prints out all elements of a one-dimension array of
int. For example, if an array of int has 3, 5, 2, 6, 3 as its elements, the
program should print{ 3, 5, 2, 6, 3 }

Write a Java program that read 2 strings. The program will print "True" to the
screen if all characters in the first string are in the second string (regardless of
case), print "False" otherwise.

For example, if the first string is "This is it." and the second string is "It is the
answer", the program will print "True". However, if the first string is "It is the
answer" and the second string is "This is it", the program will print "False", since
there is no 'a' or 'w' or 'r' in the second string.
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Lab 1 - Introduction to Eclipse.

Task | Description Result Note
1 Create workspace
2 Create a new Java Project
Import
3 e jar (or.zip) file
e Unzipped file(s)
4 Print prime numbers
5 Print array elements
6 Compare two Strings
7
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