
Jianjian Song  LogicWorks 4 Tutorials (5/15/03) Page 1 of 14 

LogicWorks 4 Tutorials 
Jianjian Song 

Department of Electrical and Computer Engineering 
Rose-Hulman Institute of Technology 

March 2003 

Table of Contents 
 
1 LogicWorks 4 Installation and update .............................................................................................2 
2 Tutorial #1: Introduction to LogicWorks 4........................................................................................2 

2.1 Objectives .............................................................................................................................2 
2.2 Starting LogicWorks 4 on your laptop.......................................................................................2 
2.3 Obtaining and placing gates in schematic window.....................................................................2 
2.4 Connecting gates ...................................................................................................................2 
2.5 Labeling inputs and output signals and pins .............................................................................3 
2.6 Connecting binary switches to input pins..................................................................................3 
2.7 Connecting binary probes to outputs of the circuit.....................................................................3 
2.8 Verifying logic function of the circuit with binary switches and probes .........................................3 
2.9 Connecting clock devices to input pins and changing clock period..............................................3 
2.10 Displaying and Changing gate delay time .............................................................................4 
2.11 Setting trigger ....................................................................................................................4 
2.12 Verifying logic function of the circuit with clocks.....................................................................4 
2.13 Verifying logic function of the circuit with device delay............................................................5 
2.14 Copying schematic and waveform to PowerPoint or Word......................................................5 
2.15 Creating signals with no waveform in a timing diagram ..........................................................5 

3 Tutorial #2: Device symbols and sub-circuits...................................................................................6 
3.1 Objectives .............................................................................................................................6 
3.2 Example sub-circuit: 74LS08 4 2-input AND gates ....................................................................6 
3.3 Draw the schematic of the following turn-signal circuit without clocks..........................................6 
3.4 Create Port Connectors ..........................................................................................................6 
3.5 Create a device symbol for the turn-signal circuit ......................................................................7 
3.6 Create a new library, my_library and save the symbol in it................................................8 
3.7 Save your turn-signal sub-circuit to another file. ........................................................................8 
3.8 Construct a turn-signal test circuit with the device symbol..........................................................8 
3.9 Create a sub-circuit and device symbol with Top-Down approach ..............................................8 
3.10 Edit a device from a library ..................................................................................................9 

4 Tutorial #3: A 4-Bit Counter Device with Bus Pins..........................................................................10 
4.1 Objectives: to create a sub-circuit and device symbol with bus pins..........................................10 
4.2 Create bus port connectors ...................................................................................................10 
4.3 Create a 4-bit counter sub-circuit with bus port connectors ......................................................11 
4.4 Create a 4-bit counter device symbol with bus pins.................................................................11 
4.5 Create a 4-bit counter with the counter symbol .......................................................................12 
4.6 Different pin names in a top-level circuit and Bus Pin Information .............................................12 
4.7 Debugging techniques ..........................................................................................................13 
4.8 Modifying a bus port in a subcircuit........................................................................................13 

5 Tutorial #4: Making a ROM device with a hex file ..........................................................................14 
5.1 Objective: to create a ROM device that is initialized by reading a text file. .................................14 
5.2 Create a plain text file...........................................................................................................14 
5.3 Create a Rom that is initialized from a file...............................................................................14 

 



Jianjian Song  LogicWorks 4 Tutorials (5/15/03) Page 2 of 14 

1 LogicWorks 4 Installation and update 
Install LogicWorks 4 from the CD from the book LogicWorks 4 Interactive Circuit Design 
Software. You will need to install an update patch LW410Update.exe that is available from 
http://www.capilano.com/LogicWorks/lw400/lw4update.html or http://www.rose-
hulman.edu/class/ee/song/ece130/. 

2 Tutorial #1: Introduction to LogicWorks 4 

2.1 Objectives 
o To build the following turn-signal circuit. 
o To verify function of the circuit with no device delay. 
o To find the output of the circuit, assuming 10-unit delay per gate. 
o To export the circuit diagram and waveform to PowerPoint or Word.
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2.2 Starting LogicWorks 4 on your laptop 

After you start LogicWorks 4, you should see a tool palette, a simulation palette, a schematic 
circuit and symbol editor window, a timing diagram window, and a device library palette. 

2.3 Obtaining and placing gates in schematic window 

On the device library palette, choose “Simulation Gate.clf” with the left mouse button. Find two-
input AND gate, AND-2. Double click the left mouse button to pick AND-2. Move the cursor to 
the schematic window. Press one of the four arrow keys on the keyboard to change orientation of 
the device. 

Each time the left mouse button is pressed a copy of the chosen device is placed on the schematic 
window. Click the right mouse button to drop the device. 

Do the same for two-input OR gates OR-2 and inverters that is denoted NOT gate in the library. 
You can rearrange the gate positions by picking one up and dragging it with the left mouse 
button. 

You can copy a gate by choosing it and choosing Edit->Copy (Control-C) and then Pasting it. 

2.4 Connecting gates 

To connect two pins with a wire, select the end of one pin with left mouse button and pressing 
and dragging the cursor to the end of the other pin. The wire can be placed piece by piece at right 
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angles by dragging and releasing the wire. A replaced wire can be rerouted by selecting and 
dragging it in any direction. 

2.5 Labeling inputs and output signals and pins 

Click on the text icon (button with letter A) in the Tool Palette. The cursor becomes a pencil. Use 
the pencil to pick a wire to be named by clicking on the wire. If your pencil is close to a pin, you 
may pick a pin instead of a wire. You can number the pin by giving it a pin number. Pin numbers 
can be seen by right clicking on a device and choosing Device Info->Pin Info. By default, pin 
numbers are in blue and signal names are in pink. 

Choose a wire instead of a pin. Type a name for the wire and then press the enter key. 

A signal name can be changed by double clicking on it and then making a change. The name can 
be dragged to another location while still associated with the same wire. Conflict will occur if two 
wires have the same name. 

Label all the signals as shown in the given circuit. Right clicking will restore cursor. 

2.6 Connecting binary switches to input pins 

Select Simulation IO.clf in the device library palette. Choose Binary Switch. Connect one binary 
switch to one input signal of the circuit. 

A binary switch can be turn on and off by clicking on it. To modify a binary switch after its 
placement, press Shift key and the left mouse button together. 

2.7 Connecting binary probes to outputs of the circuit 

Double click Binary Probe from the Simulation IO library. Move cursor to Schematic Window. 
Connect one probe on each of the two circuit outputs. 
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2.8 Verifying logic function of the circuit with binary switches and probes 

Notice that the probe values may change when the binary switches change state. 

Selecting binary switch values to generate all eight possible input combinations and record the 
output probe values. This is one way to verify the function of the circuit. 

2.9 Connecting clock devices to input pins and changing clock period 

Remove the binary switches by pressing Shift key and the left mouse button while cursor is on a 
switch and then pressing Delete key. You can also use the Zip tool to remove any device. 
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Select Clock from the Simulation IO library. Connect one clock to each input pin. 

Notice waveforms are being generated in the timing diagram window. To slow the waveform 
movement, drag to the left the speed marker in the simulation palette in between two black 
figures. 

Time interval is assumed to be a unit time, which can be defined as any convenient value. 

To change clock period, select a clock, open Simulation Parameters Dialog Box in Simulation 
menu, change low and high intervals of the clock. 

Clock period can be made visible. Select a clock with cursor, click right button to open Device 
Parameter Box. Choose Device Info, choose Attributes, select delay.Dev, and choose Visible. 
Once the clock period is visible, double click on it will open a dialog box where the period can be 
changed. 

Clicking on the sitting man in the simulation palette can stop simulation. Clicking once on the 
walking man will move simulation one step further (Single Step Mode). 

You may need to reset your simulation once in a while to make sure the signals are synchronized. 

The U-turn button on the simulation palette will reset simulation to start at time 0. 

2.10 Displaying and Changing gate delay time 

Each gate has a default delay time of 1 time unit associated with it. The delay time could be set to 
zero. To display device delay, select a device with cursor, click right button to open Device 
Parameter Box. Choose Device Info, choose Attributes, select delay.Dev, and choose Visible. 

Once device delay time is shown, click on it twice will open a delay time box. Device delay in the 
box can be changed. 

Another way to change device delay is to choose the device and select Simulation Parameters in 
Simulation Menu. Type a new delay time in delay column and choose OK. 

2.11 Setting trigger 

Page 180 of the LogicWorks 4 reference manual explains the Trigger button that shows as a small 
handgun in Simulation Palette. 

Click on the button to open Trigger Setup Box. Choose EVERY, 10 TIME UNIT, and 
REFERENCE LINE to add one reference bar on the timing diagram for every 10 time unit. Click 
OK. 

2.12 Verifying logic function of the circuit with clocks 

In order to generate all possible input combinations of the three input signals, change the periods 
of the clock signals so that they differ by multiple of 2s. For example, the three clocks can have 
periods of 320, 160, and 80 respectively. 

Click the U-turn button on Simulation Palette to reset simulation. Click the running man to run 
simulator. Click the sitting man to stop it. Move the speed marker bar to change the speed of 
simulation. 

All input combinations should appear once during one period of the slowest clock, which is 320 
units in this example.  

You can check one such period to verify the function of the circuit. 
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2.13 Verifying logic function of the circuit with device delay 

Run simulation with single steps after reset (click on the walking person on Simulation Palette) 
until a complete period of the slowest clock and observe the output waveforms to see how device 
delay affects the outputs. 

Check one period of the slowest clock to obtain the output values. 

2.14 Copying schematic and waveform to PowerPoint or Word 

A schematic can be copied to a PowerPoint or Word file through normal copy and paste 
commands. When you paste a schematic into a Word file, it will be floating over text. To change 
the image position, Click the left mouse button while the cursor is on the image. Click the right 
mouse button to open Format Picture Box. Choose Position and mask out Float Over Text. 

To copy a timing diagram, drag the cursor in the timing window to choose (mask) a section of the 
diagram that will become shaded. While the cursor is in the chosen area, click the right mouse 
button to copy the section. Inside a PowerPoint or Word file, choose Paste Special and Paste 
Bitmap. 
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2.15 Creating signals with no waveform in a timing diagram 

To make a signal appear in a timing diagram without its own waveform, select the signal in 
Timing Window, press the right mouse button and choose Remove command to delete the signal 
from the timing diagram. 

Run and stop simulation. Click on the removed signal in Schematic Window. Select Add To 
Timing in Simulation Menu to add the signal to the timing diagram. Now the signal will appear 
with no waveform. 
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3 Tutorial #2: Device symbols and sub-circuits 

3.1 Objectives 
o To make the following turn-signal circuit a sub-circuit. 
o To create a device symbol for the turn-signal circuit. 
o To draw a turn-signal circuit with the created device symbol and verify it. 
o To create a sub-circuit and device symbol with Top-Down approach. 

3.2 Example sub-circuit: 74LS08 4 2-input AND gates 

Sub-circuit and its symbol

 

A1

A2

A3

A4

B1

B2

B3

B4

X1

X2

X3

X4

A1
A1

A2

A2
A3

A3

A4

A4

B1

B1

B2

B2

B3

B3

B4

B4

X1

X1

X2

X2

X3

X3

X4

X4

 
 

08
1

4

9

12

2

5

10

13

3

6

8

11

 
 

3.3 Draw the schematic of the following turn-signal circuit without clocks 
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3.4 Create Port Connectors 

Port connectors are in part library Connect.clf. A port can be output (Port out), input 
(Port in) or bi-directional (Port Bidir). A port has port name and signal name. The port 
name is used to match with its external device pins. The port signal name matches signals in the 
sub-circuit. 

To name a port or its signal, click on the text icon (the button with letter A) in the Tool Palette 
and point to the end of the port to type a port name or the wire of the port to type a signal name. 
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Every pin that will appear in the device symbol must be declared as a port in a sub-circuit. 

Once the ports are defined, all switches and clocks should be removed from the circuit pins. 
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3.5 Create a device symbol for the turn-signal circuit 

Leave the turn-signal circuit open. 

Open a new file. Three options will appear: Design, Text document, Device Symbol. 
Choose Device Symbol and click OK. The device symbol editor is opened. 

In Options menu, select Sub-circuit/Part Type command. In Part Type, choose 
“Create a sub-circuit symbol and select an open circuit to attach to it.” 

When Select Internal Circuit dialog opens, click on the turn-signal sub-circuit. Click OK and then 
Done.  

The symbol editor has extracted all port names from the port connectors in the sub-circuit and 
placed them in the Pin List at the left side of the device symbol window. 

3.5.a Automatic Symbol Creation 

In Options menu, select Auto Create Symbol. This will bring up a dialogue box with five 
fields for you to place text into. 

In the “Left Pins” field, type the names of the inputs. Separate pin names by spaces. DO NOT 
HIT RETURN.  

In the “Right Pins” field, type the names of the outputs. 

Type the names of the control lines in either the “Bottom Pins” or “Top Pins” field. 

Place the name you would like to call the symbol in the “Part Name” field in the middle of the 
dialogue box. 

Click on Generate Symbol and the symbol will be automatically generated for you. 

3.5.b Manual Symbol Creation 

To create a symbol manually, follow the steps below. 
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Click on each pin in the Pin List and give it a pin number. 

Create a symbol for the circuit with any symbol shape. 

Place pins on the symbol by selecting the pin tool.? .  with proper directions. Notice that each new 
pin corresponds to one pin in the Pin List until all pins in the Pin List are represented on the 
device symbol. 

3.5.c Label all the pins on the device symbol and add part name 

If you create a symbol manually, you need to name all the pins. Use the text icon (button with 
letter A) in the Tool Palette to place a name for each pin inside the device symbol box. 

Open Part Attributes in Options, add a name to the device symbol such as turn-signal 
and make it always visible. You can change the orientation of a text string with Text 
Rotation in Options menu. 

3.6 Create a new library, my_library and save the symbol in it 

When you choose Save or Save As in File menu, you will be 
prompted to choose a library to save the symbol. Click New 
Library button to create a new library. Name it  my_library and 
save it in folder LogicWorks 4.0\Libs. 

Name your symbol “turn_signal” as part name for this part and save it 
in my_library. 

3.7 Save your turn-signal sub-circuit to another file. 

Close the symbol editor and be sure you have saved your sub-circuit. 

3.8 Construct a turn-signal test circuit with the device 
symbol 

Open a new design file. Get a component turn_signal 
from my_library. Add probes and binary switches to the 
outputs and inputs of the device as follows. Verify its 
functionality. 

Double click on the symbol to see the sub-circuit. Click Pop 
Up in Schematic menu to get back to the top circuit. 

3.9 Create a sub-circuit and device symbol with Top-Down approach 

We have created a device symbol with bottom-up approach in the previous sections. Now we 
want to create a device symbol with top-down approach. 

Open a new device symbol window. Create a symbol and place five pins. The pins are called 
PIN1, PIN2, etc.  

Double click on a pin name and then type another name to change the name. Name the pins to 
match the pin names in the turn-signal circuit such as R, F, L, RIGHT, LEFT, etc. 
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When you pick a pin in the pin list on the left, its type will be shown in Pin Function List. 
A pin type can be changed by selecting one of the pin functions. Set pins R, F, and L as input pins 
and LEFT and RIGHT as output pins. 

Save the symbol as a new device in my_library with any name you want to call it.. You can add 
other text on the symbol to make it easier to identify such as pin numbers and pin names. 

Open the turn-signal sub-circuit. Open a new design window in File->New. Select the new 
symbol from my_library to construct a turn-signal circuit with probes on the outputs and binary 
switches on its inputs. 

Highlight the new symbol by clicking on it. Select Attach Sub-circuit in Schematic 
Menu. Select the turn-signal sub-circuit and click Attach.  

You will see the sub-circuit schematic. Choose Pop Up in Schematic menu to go to the top 
level so that you can see the symbol. 

Verify your new turn-signal circuit by switching the input signals at the top level. 

3.10 Edit a device from a library 

To edit a device symbol from a library, choose the device and then right click on the device to 
open a device edit window. The device symbol can then to be changed. 

To change the underlying circuit for the device, select Subcircuit and Part Type in Option and 
attach the edited subcircuit to the device symbol. 
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4 Tutorial #3: A 4-Bit Counter Device with Bus Pins 

4.1 Objectives: to create a sub-circuit and device symbol with bus pins 
o To build customized bus port connectors. 
o To build a 4-bit counter sub-circuit with bus port connectors. 
o To create a device symbol for the 4-bit counter with bus pins. 
o To draw a counter circuit with the created device symbol for verification. 

4.2 Create bus port connectors 

Open a new file for creating a device symbol. In 
Device Symbol Editor, Choose “Set to primitive 
type” in Options-> subcircuit/part 
type and then choose Port Connector. The symbol 
will then be of Type Port Connector.  

Create a number of pins for a bus by choosing 
Option->Add pins with, for example, 
INPUT[A0..A3] for a four-bit input bus that has 
signals A0 to A3. 

The signal names must match those that the bus is 
to be connected to. Therefore each bus port 
connector can only be used once to connect signals 
with same names. 

A bus internal pin can be either output or input or bi-directional. 

Set pins on a bus to be output pins if the pins are to be connected to inputs of a sub-circuit. 

Draw a bus symbol that can be any 
shape you want. Select a bus pin from 
the symbol palette and place it on the 
bus symbol. There are four bus pins, 
one for each side of the bus symbol. 

A screen capture on the right shows 
how a 4-bit input bus port can be 
created. Notice that the pin functions 
are designated as Output, although the 
bus port is an input bus port. 

Make sure the pin directions and the 
number of pins match the intended 
application. 

Save the port connector symbol to your 
own library. The following are two 
sample port connector symbols.

4-bit Bus Port In  

1 bus port out
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4.3 Create a 4-bit counter sub-circuit with bus port connectors 

Bus port connectors can be used like Port In and Port Out connectors in a sub-circuit. When 
connecting a bus port to a breakout, make sure the corresponding pin names are exactly the same. 
For example, the breakout D0-3 matches the Bus Port In that has input pins D0-3. 

Here is a subcircuit with the bus ports. 
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4.4 Create a 4-bit counter device symbol with bus pins. 

The procedure is the same as that of creating a device symbol from a subcircuit. However, pin 
function for input pins should now be changed to Input. And pin function for output pins should 
be Output as shown in the following picture. 

When a subcircuit with bus ports is attached to a device symbol, it is possible that the pin 
directions are all reversed. Therefore, it may be necessary to manually change pin directions. 
Check all pin directions to make sure they are correct, i.e., output pins should have pin type of 
output and input pins should have pin types of input.
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4.5 Create a 4-bit counter with the counter symbol 

Now the device symbol can be tested with I/O devices as follows. 
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4.6 Different pin names in a top-level circuit and Bus Pin Information 

When a device symbol with bus ports is used in a top-level circuit, pins connected to a bus port 
may have different names from those in the bus 
port. Bus Pin Info pop-up menu can be used to 
associate top-level pin names to those of a bus 
port. 

The following example shows how Q0 to Q3 can 
be associated with OUT0 to OUT3. It was done 
by selecting Q0 in the bus pin list and OUT0 in 
the bus list and then selecting Join Sequential. 

Here is a screen capture of 
the actual circuit. 
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4.7 Debugging techniques 

After a bus port is connected to pins in a 
subcircuit, right click on the bus symbol to 
open Device Info window. Check each pin 
of the bus to see if their types are correct. 
For example, all the pins of an output bus 
port should have pin type of Output. 

 

 

 

Once a device symbols is corrected. Get a 
copy of it in a schematic window. Right click on a bus pin of the device symbol to open Bus Pin 
Info window. Choose a pin and click Pin Info to find out if the pin is of correct type. If it does not 
have the correct type, edit the device symbol to check if the pin type is defined correctly.

 
 

4.8 Modifying a bus port in a subcircuit 

After modifying a bus port in a subcircuit, the subcircuit needs to be detached and reattached to 
the device symbol.  

A subcircuit can be detached with Schematic ->detach subcircuit at either device symbol level or 
subcircuit level. 

A device symbol can get a new subcircuit by selecting it and then choosing Schematic ->attach 
subcircuit. 
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5 Tutorial #4: Making a ROM device with a hex file 

5.1 Objective: to create a ROM device that is initialized by reading a text file. 

5.2 Create a plain text file 
ROM content can be stored in a plain text file as hexadecimal numbers. One easy way to do it is 
to have one line for each memory location. Here is an example of 4x92 ROM with two address 
lines and 92 bits at each address. Every line in the text file must have exact the same number of hex 
numbers as the bit length. LogicWorks reads each line with left alignment. If the number of bits is not 92 
on a line, the highest bits will not be initialized. 
 

436F6B65202020202020050 

4469657420436F6B6520050 

436865727279436F6B65350 

4C6970746F6E20546561400 
The first ten byes in each line are ASCII characters and the last three hex numbers are binary numbers. 
They represent the following text. 
 
Coke $0.50 
Diet Code $0.50 
CherryCoke $3.50 
Lipton Tea $4.00 
 
There may be spaces in between the characters and the three digit number if a name has less than ten 
characters. 
 

5.3 Create a Rom that is initialized from a file 
Choose Simulation-PROM/RAM/PLA Wizard. Select PROM and click next. In the PROM Symthesizer window, 
select Read data from a raw hex file and click next. Choose Select Raw Hex File and choose the file to be read from. 
If there is no error opening the file, it will be read and the ROM will be initialized with content from the file. You 
can now save the ROM as a component. 
 

  
 


